安装 ntop 提示 Missing Dependency: librrd_th.so.2 错误

centos 5.6 x64 安装 ntop 提示以下错误

Resolving Dependencies
--> Running transaction check
---> Package ntop.x86_64 0:3.3.9-7.el5 set to be updated
--> Processing Dependency: graphviz for package: ntop
--> Processing Dependency: librrd_th.so.2()(64bit) for package: ntop
--> Processing Dependency: libnetsnmp.so.10()(64bit) for package: ntop
--> Processing Dependency: libGeoIP.so.1()(64bit) for package: ntop
--> Running transaction check
---> Package geoip.x86_64 0:1.4.6-1.el5.rf set to be updated
---> Package graphviz.x86_64 0:2.22.0-4.el5.rf set to be updated
--> Processing Dependency: libXt.so.6()(64bit) for package: graphviz
--> Processing Dependency: libgs.so.8()(64bit) for package: graphviz
--> Processing Dependency: libXaw.so.7()(64bit) for package: graphviz
--> Processing Dependency: librsvg-2.so.2()(64bit) for package: graphviz
--> Processing Dependency: libXmu.so.6()(64bit) for package: graphviz
---> Package net-snmp-libs.x86_64 1:5.3.2.2-9.el5_5.1 set to be updated
---> Package ntop.x86_64 0:3.3.9-7.el5 set to be updated
--> Processing Dependency: librrd_th.so.2()(64bit) for package: ntop
--> Running transaction check
---> Package ghostscript.x86_64 0:8.70-6.el5 set to be updated
--> Processing Dependency: urw-fonts >= 1.1 for package: ghostscript
--> Processing Dependency: ghostscript-fonts for package: ghostscript
---> Package libXaw.x86_64 0:1.0.2-8.1 set to be updated
---> Package libXmu.x86_64 0:1.0.2-5 set to be updated
---> Package libXt.x86_64 0:1.0.2-3.2.el5 set to be updated
---> Package librsvg2.x86_64 0:2.16.1-1.el5 set to be updated
--> Processing Dependency: libgsf >= 1.6.0 for package: librsvg2
--> Processing Dependency: libcroco >= 0.6.1 for package: librsvg2
--> Processing Dependency: libgsf-1.so.114()(64bit) for package: librsvg2
--> Processing Dependency: libcroco-0.6.so.3()(64bit) for package: librsvg2
---> Package ntop.x86_64 0:3.3.9-7.el5 set to be updated
--> Processing Dependency: librrd_th.so.2()(64bit) for package: ntop
--> Running transaction check
---> Package ghostscript-fonts.noarch 0:5.50-13.1.1 set to be updated
---> Package libcroco.x86_64 0:0.6.1-2.1 set to be updated
---> Package libgsf.x86_64 0:1.14.1-6.1 set to be updated
---> Package ntop.x86_64 0:3.3.9-7.el5 set to be updated
--> Processing Dependency: librrd_th.so.2()(64bit) for package: ntop
---> Package urw-fonts.noarch 0:2.3-6.1.1 set to be updated
--> Finished Dependency Resolution
ntop-3.3.9-7.el5.x86_64 from epel has depsolving problems
  --> Missing Dependency: librrd_th.so.2()(64bit) is needed by package ntop-3.3.9-7.el5.x86_64 (epel)
Error: Missing Dependency: librrd_th.so.2()(64bit) is needed by package ntop-3.3.9-7.el5.x86_64 (epel)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

明明已经装了 rrdtool 呢,还是提示错误,google 之,原来是 rrdtool 太新了,

yum remove rrdtool
yum install rrdtool-1.2.27-3.el5.x86_64
yum install ntop

OK 搞定

One thought on “安装 ntop 提示 Missing Dependency: librrd_th.so.2 错误

发表评论

电子邮件地址不会被公开。 必填项已用*标注