ros routeros限速和限线程脚本

限线程脚本:

:for aaa from 2 to 254 do={/ip firewall filter add chain=forward src-address=(192.168.0. . $aaa) protocol=tcp connection-limit=50,32 action=drop}

限速脚本:

:for aaa from 2 to 254 do={/queue simple add name=(queue . $aaa) dst-address=(192.168.0. . $aaa) limit-at=0/0 max-limit=2000000/2000000}

说明:
脚本为一行不是两行
aaa是变量
2 to 254是2~254
192.168.0. . $aaa是IP
上两句加起来是192.168.0.2~192.168.0.254的意思
connection-limit=50是线程数这里为50
max-limit=2000000/2000000是上行2m/下行2m

使用:
WinBox-System-Scripts-+
Name(脚本名程)
Source(脚本)
OK-选择要运行的脚本-Run Script

查看规则是否填加进来:
限线程:WinBox-IP-Firewall-Filter Rules
限速:WinBox-Queues-Simple Queues
——————————————————————————–

手动设置限速

winbox—queues—-simple queues

点“+”,NAME里随便填,下面是IP地址的确定

①Target Address 不管,Dst. Address里填 你要限制的内网机器的IP,比如我这里有个 1号机器 IP为 192.168.1.101,那dst.address 里就填 192.168.1.101 然后是/32(这里的32不是指掩码了,个人理解为指定的意思)!

②interface里 记着要选你连接外网那个卡,我这里分了“local和public”,所以选public

③ 其他的不管,我们来看最重要的东西拉,Max limit ,这个东西是你限制的上限,注意的是 这里的数值是比特位,比如我要限制 下载的速度为 500K 那么就填入多少呢? 500 X 1000 X 8=400 0000=4M。

④ 另外,很多朋友都有个疑问,到底一般的用户会有多大流量呢?一般的网络游戏,如 梦幻西游 传奇 封神榜 等等,其下行在 20Kbps以内! 最耗网络资源的就是下载—–我们就是为了限制它拉,其次是VOD点播,一般DVD格式的大约要 2M多吧,所以你看情况限制拉 别搞的太绝!!!

原文 http://hi.baidu.com/1019xj/blog/item/02f8321f936aa2c8a6866932.html

发表评论

电子邮件地址不会被公开。 必填项已用*标注